
182

Understanding
Computer Applications UNIT 11 INTRODUCTION TO MICROSOFT

EXCEL

Structure

11.1 Introduction

11.2 Starting Excel
11.2.1 Excel Worksheet

11.3 Navigating Worksheets

11.4 Entering Data

11.4.1 Entering Text

11.4.2 Entering Numbers

11.4.3 Entering Date and Time

11.4.4 Entering Formulas

11.5 Excel Functions

11.6 Selecting Cell Ranges

11.7 Creating Text, Number and Data Series

11.7.1 Creating Text Series

11.7.2 Using the Autofill  Feature

11.8 Editing Worksheet Data

11.8.1 Clearing a Cell

11.8.2 Copying Data

11.8.3 Cut and Paste

11.8.4 Inserting and Deleting Rows, Column and Cell Ranges

11.9 Worksheets Formatting

11.9.1 Numeric Formatting

11.9.2 Custom Formats

11.9.3 Data and Time Format

11.10 Changing Column Width and Row Height

11.10.1 Changing Column width

11.10.2 Change Row Height

11.11 Auto Formats

11.12 Aligning Data

11.12.1 Horizontal Control

11.12.2 Orienting Text

11.12.3 Controlling Text Within a Cell

11.12.4 Applying Borders

11.13 Working With Graphic Objects

11.13.1 Adding Graphic Objects to a Worksheet

11.13.2 Selecting, Resizing Objects

11.13.3 Creating A Text Box

11.14 Charts

11.15 Let Us Sum Up

11.16 Check Your Progress Exercise

11.17 Answers to Check Your Progress Exercise



Introduction to
Microsoft Excel

183

11.1 INTRODUCTION

MS Excel is an electronic spreadsheet. A spreadsheet is a generic term for the software
package that simulates a paper worksheet often used by people in management. Most
spreadsheets started as electronic versions of hard copy accounting worksheets
with one major purpose – simple row and column arithmetic. It has various features to
offer – namely, fast calculations, what-if analysis, charts (also called graphs), automatic
re-calculations, and many more. It has user interface features common to other Microsoft
Office Applications.

A variety of applications for which MS-Excel can be used include automating financial
statements, business forecasts, transaction registers, inventory control, accounts
receivable and accounts payable. MS-Excel provides statistical, analytical and scientific
functions.  Excel comes across as a powerful and flexible graphical presentation tool.
Data stored in database formats can be accessed through MS-Excel.

It supports what-if analysis to help predict the future values if there is a change in the
cell content which is referred to in the formula. Graphs or charts can be created
based on data for quick assessment of a situation. Macros which can be used to combine
a series of actions to automate your work., can also be defined. Excel can create
formulas by using row and column headers instead of range references.  This feature
is known as the Natural Language formula. Page Break Preview feature permits you
to move page breaks by dragging them. We shall learn about these MS Excel features
in this unit.

Objectives

After going through this unit, you will be able to:

� understand the features of Excel,

� navigate worksheets,

� make different types of entries in a worksheet,

� use sample statistical functions,

� create text, numbers and date series,

� save and edit worksheet,

� format worksheet formatting,

� work with graphic objects, and

� create charts.

11.2 STARTING EXCEL

Microsoft Excel can be started in following way:

1. Click on the Start button in the Windows environment.

2. Select Programs option from the Start menu.

3. Select Microsoft Excel option from the Programs submenu. The screen as
illustrated in Figure 11.1 is displayed.

Debugging is finding
and removing errors
(bugs) from a
program.

NOTE
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11.2.1 Excel Worksheet

When you start Excel, workbook is displayed. It is here that Excel stores all its data and
allows manipulation. A workbook is a collection of individual worksheets, each of which
can hold data.  All actions and operations of Excel take place in the worksheet. Excel has
65536 rows and 256 columns in its worksheets.

Each worksheet is made up of cells, and cells are a result of intersection of rows and
columns as you can see in Figure 11.2.  They are the basic units for storing data. Each
cell gets its name from this intersection.  The address of a cell that is in column A and has
its row number as 4 is referred to as cell A4. A group of contiguous cells is called a range.
An example of a cell range would be G1:G3.

Cell A1,A2 contains the label Chandan,Yashpal.

Cells B4 and C4 contain the value 400 and 800 respectively.

Cell G4 contains the formula  = C4-B4.

Pressing the Enter key will result in G4 holding the result of the formula = (C4-B4).

All formula entries should begin with an = (equal to) sign.

You can make a cell active by clicking on it. Files created by a spreadsheet package are
known as worksheets.  Automatic recalculation feature hastens the calculation tasks. If
data in cell C4 is changed from 800 to 900, then the formula in cell G4 would calculate the

Formula BarFormatting ToolbarMenu Toolbar Standard Toolbar

Figure 11.1: Microsoft Excel

Figure 11.2:   Excel worksheet
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result based on the new C4 cell content.  This is due to the fact that, once the formula is
created with cell references in it, it establishes a relationship with the specified cell
references or addresses.

11.3 NAVIGATING WORKSHEETS
A1 is always the active cell in a new worksheet by default, but if you want to move on to
another cell for data entry, then you can make that cell active by moving the mouse
pointer on it and clicking on it.

You can move around in a worksheet with the aid of a mouse or the keyboard, or by using
the menu bars.

You can use the arrow keys, Page Up, Page Down and a host of other keys in combination,
to move around in the worksheet.

To move in the worksheet by using the Menu bar:

Select the Go To option from the Edit menu or press the F5 function key to open up the
Go To dialog box and E2, type the reference of the cell, click on the OK button of the Go
To dialog box. The cell pointer moves to cell E2 immediately.

To move in the worksheet using the Mouse:

Select the cell you want to activate. Place the mouse pointer on it. Click to activate it.

11.4 ENTERING DATA

Active cell is indicated by a rectangle boundary over that cell.  Data entry is accomplished
by feeding the data in the active cell.  As you type, the data is displayed in the active cell
as well as in the formula bar.

There are three boxes that exist between the Formula Bar and the Name Box.

The first box with a cross (x) symbol cancels your entry made in the cell.

The second box with a right mark allows acceptance of data in the cell.

The third box contains an equal to (=) sign. This is the Edit Formula feature that simplifies
the calculation tasks.

11.4.1   Entering Text

Text entries can be numbers, letters or symbols.  Numbers can also be treated as text,
especially in cases where calculations are not required; for example, telephone numbers,
record numbers, zip codes, roll numbers, and so on.

Excel studies the entered data to determine the type. If you type an address which is
alpha-numeric in nature, it is automatically taken as a text entry; For example, Block 11,
IGNOU, 10 Ashoka Road.

Numeric entries that are to be treated as text should be preceded with an apostrophe; for
example, ’64. It is then considered as text entry.

Name Box Cancel Button Enter Button
Formula Bar

Edit Fomula Button



186

Understanding
Computer Applications

11.4.2   Entering Numbers

Numeric entries are constants and can be integers, decimal fractions, integer fractions
and scientific notations. For example (9.994E+0.05).  If #### symbol occurs when you
make a numeric entry, it implies that the number is very long and the column width not
wide enough to accommodate it.

11.4.3   Entering Date and Time

Date and time entries can also be made in Excel worksheets. Excel allows calculation on
dates because it converts the entry to a serial date number; for example, you can find out
the age of a person by reducing the current date from his date of birth. Excel recognizes
date and time only when they are specified in the right formats. The valid formats for the
date and time are:

Valid Date Format Valid Time

6/10/, 6-OCT-, 6-OCT, OCT-6 11:30, 11:30:20, 2:30 AM

11.4.4 Entering Formulas

Excel uses formulas for calculations. Formulas can be simple as well as complex in
nature.

Using a formula, expressions can be calculated by typing the formula in the appropriate
cell; for example, = B4+C5 is a formula that adds the cell content of cell B4 to the cell
contents of Cell C5. The formula specified must be preceded by an equal to (=) sign.

= 35 * 44

= 23 ^ 2

= C5 – C3

= C1 + C2 + C3 + C4 + C5

= S3 – D6 * 44/3

Formulas can also contain named cells or cell ranges. Excel formula functionalities lie in
the fact that it can relate the formula to the cells referred in it and, if the contents of these
cell change, a new result is calculated with the aid of the automatic recalculation nature.
The formula entered in an active cell is also displayed in the formula bar as you enter it.
To display the result of the calculated expression in the active cell, press the Enter key.  It
is to observe that the cell displays the result, and the formula bar displays the formula or
expression.

11.5  EXCEL FUNCTIONS

Functions can be used to calculate formulas and expressions in Excel. Functions are
predefined formulas that performs calculations by using specified values called arguments
in a particular order, called the syntax; For example, the SUM function adds the values
or ranges of cell.

To enter a formula that contains a function, follow the steps:

1. Click on the cell in which you want to enter the formula.

2. To start the formula with the function, click on the Edit Formula button in the formula
bar.

3. Click on the down arrow head right next to the Functions box to invoke a drop-down
list of available functions, which include SUM, COUNT, AVERAGE, MAX, etc. as
illustrated in Figure 11.3.
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4. Click on the function you want to add to the formula. If the function does not appear
in the list, click on More Functions.

5. Enter the arguments for the function.

6. When you complete the formula, press the Enter key.

The other convenient way of choosing functions is by using the Paste function that appears
on the standard toolbar as  fx  symbol.

You can also select the Function option from the Insert menu to select an Excel function.
Both the actions invoke the Paste Function dialog box  as indicated in Figure 11.4.

The Function category list displays Excel’s built-in functions. Select the required function
from the list. If you are not sure which function to select, there is a Help button in the
Office Assistant to guide you.

11.6 SELECTING CELL RANGES
Cell ranges are required to be selected for calculation, and clicking on each one of them
becomes a very tedious task. Cells can be selected using keyboard, mouse. To select a
cell range for an instance, you can do the following:

Enter button

Cancel button
Edit Formula  button

Down  arrow head

Function   Box

Figure 11.3: Excel functions

Figure 11.4: Paste function dialog box
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Using the Keyboard

1. Move the cell pointer at the corner of the cell range which you want to select.

2. Click on the starting cell of the range.

3. Press and hold down the Shift key and then press the arrow keys to select the
range.

Using the Mouse

1. Click on a corner of the range you want to select.

2. Drag the mouse over the range.

3. When you reach the end of the range, release the mouse button [refer to Figure
11.5(b)].

11.7 CREATING TEXT, NUMBER AND DATE SERIES
You may sometimes find yourself in a situation where you need to key in a series of text,
dates, time or numbers.  A time series, for example, can include increments of days,
weeks or months.  It can include repeating sequences such as weekdays, month names
or quarters. In such cases, specifying the initial time selections and the last value of the
series would result in the entire series being generated automatically by Excel. A few
examples of time series have been given below :

Initial Selection Extend Series

1, 2 10:00, 11:00, 12:00

Mon Tue, Wed, Thursday

Jan Feb, Mar, Apr

You can also generate linear series and growth series by selecting the initial values for the
series and positioning them in the first two cells of the range of cells to be generated.
Examples of linear and growth series are given below:

Initial Solution Extended linear Series

1, 2 3, 4,5

100, 95 90, 85

1, 3 5, 7,9

Figure 11.5 (a) : Selecting Cell Range using keyboard

Figure 11.5 (b) : Selecting Cell Range using mouse
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Text, date, time and other series can be generated by using the following:

� AutoFill feature (AutoFill handle is the small plus sign at the bottom right corner of
the active cell)

� Menu bar

� Shortcut menu

11.7.1 Creating Text Series

To fill a range of cells with text entries, such as days, months, and so on, or fill a range of
cells with text using the AutoFill feature, follow the steps:

1. Enter the first value in the cell which would be at the beginning of the series, and
select the cell. Look at Figure 11.6 (a).

2. Drag the AutoFill handle across the cell that you want to fill.

3. Release the mouse button.

4. Excel files the range of selected cells with the appropriate text entries.

Use the menu bar to perform the same task by following these steps:

1. Enter the first value and select the range to be filled.

2. Select the Fill option from the Edit menu

3. Select the Series option from the Fill submenu.

4. Indicate whether you want to fill your series in rows or columns as illustrated in
Figure 11.6 (b).

5. Specify the type of series you want you create – Linear, Growth, Date or AutoFill.

6. You can now specify the step and the stop values.

7. You can create series such as:

4:00, 5:00, 6:00, 7:00

Redg100, Redg101, Redg102

Figure 11.6 (a) : Creating Text Series using AutoFill Feature

Figure 11.6 (b) : Creating Text Series using menu bar
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Jan, Feb, Mar

Sun, Mon, Tue

North, South, East, West

The method for entering series of dates, series of numbers is same as given above. You
can enter a series of numbers or series of dates where incrementation and decrementation
of numbers is by a specific value. Suppose you want to generate a list of even numbers.
You can do it in the following ways:

11.7.2   Using the AutoFill Feature

1. Enter the number 2 or any date in the first cell and the number 4 or any other date
in the second cell.

2. Select both the cells.

3. Drag the AutoFill handle over the range of cells you want to fill.

4. Release the mouse button.

Excel fills the range of cells with the appropriate entries.

You can also use the Series option from the Fill submenu of the Edit menu for generating
a series of numbers.

Saving Workbooks

Whenever workbooks are created, they are named, by default as Workbook1, Workbook2,
and so on. Saving the worksheets of these workbooks makes them permanent.  To save
the work on your worksheets, you should follow the steps:

1. Select the Save option from the file menu to save it the disk.

2. You can also click on the Save button on the standard toolbar.

3. Name the file you have saved and specify the location at which the workbook
should be placed as illustrated in Figure 11.7 above.

Saving Multiple Files

When you have a number of files that are open, you can very conveniently save them all.
You can select the Exit option from the File menu and click on the Yes To All button in the
Save As dialog box that is displayed.

Figure 11.7 : Saving workbook
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Saving as an HTML File

Excel allows you to publish your workbook data on the Web and even move to other files
by using hyperlinks.

You can also save an Excel worksheet as an HTML file for publishing on the World Wide
Web. To do so, you can select the Save As HTML option.

11.8 EDITING WORKSHEET DATA
The data that exists in cells may require some editing, such as moving data from one
location to the other, clearing cell contents, and so on.  You can edit the contents of the
cell by using the formula bar or the In-Cell editing option as described below:

Formula Bar Method

1. Select the cell you want to edit.

2. Click on the formula bar or press the F2 function key.

The contents of the cell gets displayed in the formula bar which can be edited accordingly.

In-Cell Editing

To edit the contents of a cell:

1. Double-click on the cell.

The insertion point appears at the end of the cell  which can be moved to the required
position for editing.

11.8.1    Clearing a Cell

To clear a cell is to erase the cell content but it is not similar to deleting a cell. Deleting a
cell or cells causes the other cells on the right or bottom to shift positions. Clearing cells,
on the other hand, does not cause the other cells to shift.  There are different ways of
clearing cell contents.

(i) To clear a cell using shortcut menu:

1. Highlight the cell or range of cells to be cleared.

2. Click on the right mouse button. The window displayed is illustrated in Figure 11.8.

3. Select the Clear Contents from the shortcut menu.

(ii) To clear the cell contents by using the Delete key, follow the steps:

1. Select the cell and use the Delete key to clear a cell.

Excel clears all the data from the cell, but does not change cell formatting.

Figure 11.8 : Clearing a cell
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(iii) To clear the contents of a cell using menu bar, follow the steps:

1. Select the cell or range of cell.

2. Select the Clear option from the Edit menu.

The submenu that appears has the options:

� Contents – clears the cell contents

� Comments – clears the comments in the cell

� All – to clear everything from the cell, including formatting and cell Notes.

� Formats - to clear only cell formatting from the cell.

11.8.2 Copying Data

To create multiple copies of worksheet data, you use the Copy and Paste feature of
Excel.  This makes it easier to copy the contents of the cells than typing the data all over
again.  The task can be accomplished in several ways.

(i) Using the menu bar, you need to:

1. Select the cell or range of cells having the cell contents that are to be copied.

2. Select the Copy option from the Edit menu.

3. Select the cells in which you want to paste a copy of the data.

4. Select the Paste option from the Edit menu or press Ctrl + V. The data gets
copied from source cell to copied cell as shown in Figure 11.9.

(ii) You can use the shortcut menu to copy and paste by following the steps:

1. Select the range of data that you want to copy.

2. Click on the right mouse button.

3. Select Copy from the shortcut menu.

4. Select the cells in which you want to paste your data.

5. Click on the right mouse button again and select the Paste option from the
shortcut menu.

Drag and Drop Method

(iii) To use the drag and drop method to copy and paste data, follow these steps:

1. Select the cells you want to move.

2. Point to an outside edge of the selected range by using the mouse.

Source   Cell

Copied Cell

Figure 11.9: Copying data
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3. Click on the selection, press and drag the cells to a new location and then
release the mouse button.

(iv) The AutoFill command enables you to copy contents to adjacent cells. To do so,
you can follow the steps:

1. Select the cell or range of cells that contains the data you want to copy.

2. Position the mouse pointer on the Fill handle.

3. Drag the Fill handle over the adjacent cells.

The cell contents would be copied in the adjacent cells.

4. Release the mouse button.

11.8.3   Cut and Paste

When you select the Cut command to move the data, a copy of the data is stored in the
window Clipboard. Later when you use the Paste option, the data is placed in another
area of the worksheet. The method for performing cut and paste is similar to copy
except the fact that instead of copy, cut is selected from menu.

11.8.4   Inserting and Deleting Rows, Column and Cell Ranges

You can insert rows, columns and cell ranges, if required.  Insertion of rows, columns,
and cell ranges always cause the data already in the worksheet to shift position to
accommodate the insert object. The method for deleting/inserting rows/columns is
similar to deletion/insertion of cell except that new cell is to be selected.

1a) To insert a column using the main menu, the steps are:

� Position the cell pointer on the column where you want the new column should
be inserted. Select the Column option from the Insert menu.

� Excel inserts a new column and the existing columns shift to the right.

1b) To insert a column using the shortcut menu, the steps are:

� Position the cell pointer in the column where you want your new column
should be inserted.

� Click on the right mouse button on the column header and select the insert
option from the shortcut menu as shown in Figure 11.10.

2a) To delete a column using the main menu, the steps are:

� Click the letter of the column you want to delete. Select the Delete option
from the Edit menu.

Figure 11.10: Insert column using shortcut menu
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2b) To delete a column using the shortcut method, the steps are:

� Select the letter of the column you want to delete. Click on the right  mouse
button and select the delete option from the shortcut menu.

3a) To insert a row using the main menu, the steps are:

� Select a cell in the row below the location where the new row should appear.
Select the row option from the insert menu.

3b) To insert a row using the shortcut menu, the steps are:

� Select a cell in the row below where the new row should appear.

Click the right mouse button on the row header and then select Insert option
from the shortcut menu.

4a) To delete a row using the main menu, the steps are:

� Select the row which you want to delete. Select the Delete option from the Edit
menu.

4b) To delete a row using the shortcut menu, the steps are:

� Select the row  which you want to delete.

� Click the right mouse button and select the Delete option from the Shortcut
menu.

Naming the Sheets

Excel has its worksheets named as sheet1, sheet 2, sheet 3, and so on. Sheets can be given
other names which may prove to be more convenient for task identifications; for example,
workbook1 may contain sheets called Student, Marksheet,  Attendence, and so on.

To name a sheet, follow the steps:

1. Double-click the sheet tab to which you want to give a new name.

The Rename dialog box gets invoked where the new name can be specified.

1. Or you could go to the sheet tab and click on the right mouse button.

2. Select Rename.

Once the dialog box is displayed, give the new name and click on the OK button.

11.9 WORKSHEETS FORMATTING
Excel like other windows based programs is a graphically rich spreadsheet program, so it
has a great potential of enhancing its worksheet appearance. Data arrangement and
presentation is conveniently accomplished by its simple formatting  tools. Formatting plays
an important part during report generation.

11.9.1    Numeric Formatting

Appearance of numeric entries can be changed by using the numeric format functionality
offered by Excel. Excel offers various formatting styles but you can also specify your
own formatting styles.

(a) Using Shortcut menu

You can format numeric entries by using the shortcut menu.  To do so, follow the steps
listed herewith:

1. Select the cells containing the data.
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2. Click on the right mouse button.

3. Select the Format Cells option from the shortcut menu.

The format cells dialog box gets invoked as shown in Figure 11.11(a).

4. Select the type of number format you want to apply from the category list.

5. If you select Date, Time, Fraction, Special or Custom category, then a sample format
is shown to you in the sample area.

6. If you select Number, Currency, Accounting, Percentage or Scientific categories,
then an option for setting the decimal places is available to you.

7. General and text entries do not offer any options.

8. Select the number format you want.  When you make a choice, then a sample of the
choice that you have made is shown in the sample area.

9. Select the OK option to allow Excel to apply the numeric format.

(b) Using the Style menu

You can also use the Style menu to format numeric entries. To do so, follow the steps
listed herewith:

1. Select the cells containing the numbers you want to format.

2. Select the Style option from the Format menu. Style dialog box gets invoked as
shown in Figure 11.11(b).

3. Select the style you want from the Style name drop-down list.

4. Select the OK option.

Figure 11.11(a): Numeric Formatting using shortcut menu

Figure 11.11 (b): Numeric formatting using style menu
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(c) Using the Toolbar

Formatting toolbar helps you to quickly select the formatting styles which are frequently
used, such as currency, percentage and comma.

1. Select the cell containing the numbers.

2. Click on the appropriate button from the toolbar.

11.9.2     Custom Formats

There are times when you require special kind of formatting that Excel is incapable of
providing from its built-in number formatting styles, for example, having an international
currency symbol or displaying the numbers in thousands without changing the actual cell
values.  For such special tasks, a custom number format is required.

(i) Creating a Custom Number Format

To create a custom number format, the steps are:

1. Select the Cells option from the Format menu.

2. Select the Number tab from the Format Cell dialog box as shown  in Figure 11.12.

3. Select Custom in the Category list box.

4. Select the predefined format in the Type list box.

(ii) Applying Custom Number Format

Once a custom number format is defined, it is stored in the workbook and can be used
again whenever required.  Custom formats are displayed in the Number tab of the Format
cells dialog box at the end of the custom category.

(iii) Deleting Custom Number Formats

Custom formats are stored in the workbooks in which they are defined. If you want to
delete them, activate the workbook and then follow the steps given herewith:

1. Select the Cells Option from the Format menu.

2. Select the Custom category.

3. Select the Custom format you want to delete.

4. Click on the Delete button.

11.9.3 Date and Time Formats

Excel understands most dates and times entered in a worksheet cell and then it displays
them in their respective formats. You can change the date and time formats to specify
your own. To apply a new format, the steps are:

Figure 11.12: Creating a number format
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1. Select the cell or range containing the data you want to format.

2. Select the Cells option from the Format menu.

3. Select date from the Category list to display the list of date formats.

4. Select the format you want to use from the Type list box.

5. Select the OK button.

11.10 CHANGING COLUMN WIDTH AND ROW
HEIGHT

The data that you enter in the cells is sometimes too long for the column width to
accommodate. You can increase the column width and row height to display the entire
cell entry.

11.10.1   Changing Column Width

Column width can be changed by using the mouse or the menu commands.

(i) To change the column width using the mouse:

1. Position the mouse pointer on the right border of the heading of the column that
has the width to be changed.

2. Press the mouse button and drag it to the right to increase the column width or
towards the left to decrease the width.

3. Once the right width has be selected, release the mouse button.

(ii) To change the column width using the menu bar, the steps are:

1. Click on the heading of the column that has the width you want to change.

2. Select the Column option from the Format menu. The window displayed is
shown in Figure 11.13.

3. Select the Width option from the Column submenu.

The column width dialog box is displayed as shown in Figure 11.13.

4. Enter the column width in the column width text box.

5. Select the OK option.

11.10.2    Changing Row Height

Change the row height by using the mouse and the menu bar.

(i) To change the row height by using the mouse, the steps are:

1. Position the mouse pointer on the heading of the row (where the row numbers
are specified) having the height you want to change.

2. Press the mouse button. A double headed arrow is displayed.

3. Drag the arrow down or up to increase or decrease the row height.

4. Release the mouse button when the appropriate height is selected.

Figure 11.13: Changing Column Width
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(ii) To change the row height by using the menu bar, the steps are:

1. Click on the heading of the row whose height you want to change.

2. Select the Row option from the Row submenu.

3. Select the Height option from the Row submenu.

The row height dialog box is invoked as shown in Figure 11.14 above.

4. Enter the row height in the Row Height text box.

5. Select the OK option.

A sample of increased column width and row height has been shown in Figure 11.15.

11.11 AUTOFORMATS

Various pre-designed formatting templates called AutoFormats are present in Excel. These
designs include specific selections from Excel’s borders, fonts, patterns and alignment,
numeric formatting options as well as adjustment in column width and row height.  To
apply the AutoFormat to a range of cells, the steps are:

1. Select a range of cells

2. Select the AutoFormat option from the Format menu.

The AutoFormat dialog box is displayed as shown in Figure 11.16.

3. Select an AutoFormat style from the Table Formatting list.

4. Select the OK option.

Figure 11.14: Changing Row Height using menu bar

Figure 11.15: Sample of Increased Column Width and Row Height

Figure 11.16: AutoFormat dialog box
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11.12 ALIGNING DATA
Excel allows manipulation with alignment. It can align data within a cell horizontally or
vertically. Alignment is the positioning of the characters text and numbers within a cell in
which, by default, the text is left-aligned and the numbers are right-aligned. To change
the alignment, the steps are:

1. Select the Cells option from the Format menu.

2. Select the Alignment tab to display the Format Cells dialog box as shown in
Figure 11.17.

The text alignment area shows horizontal and vertical list boxes:

11.12.1     Horizontal Control
To align the text horizontally within a cell, there are several option are in the table like

General -  This option aligns the text to the left and numbers to right.

Left -  Aligns cell contents to the left.

Center – Centers the characters within a cell.

11.12.2   Orienting Text
In the orientation section, you can specify the manner in which you want your text to be
oriented. The setting on the dialog box displays the style in which your text would appear.
To rotate the text, select the desired degree of rotation in the degree scroll box, or click on
the rotation angle in the horizontal orientation display box. An example of text rotation is
shown in Figure 11.18.

Figure 11.17: Format Cell Display

Figure 11.18: Text Rotation
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11.12.3    Controlling Text Within a Cell

There are a number of options available through the alignment tab to change the appearance
of the text within a cell. These options are:

Wrap Text:  This option breaks a long line of text into multiple lines to fit within a cell
(refer to Figure11.19).

Shrink to fit: This option changes the font size instead of the row height, shrinking the
text to fit in the cell.

Merge Cells : This a powerful new feature. It allows you to merge several cells together
to act as one without changing the row height or column width.  This is a very important
feature, especially when the worksheet is to be incorporated with some special explanatory
notes, labels or a addresses for which whole column width incrementation is not suitable.

11.12.4   Applying Borders

Borders helps to demarcate one cell range from another. It acts as a separator. It also
improves the appearance of the printed reports.

To apply borders, the steps are:

1. Select the Cells option from the Format menu.

2. Select the Borders tab from the Format Cells dialog box as shown in Figure 11.19.

You can select one of the preset borders that are available. These are:

None : which implies no borders.

Outline : which puts a border around the outer edge of the select cells.

Inside : which applies a border on the inside grid of the selected cells.

3. You can create your own border with the aid of the border buttons available to you.

Figure 11.19: Controlling text within cell

Figure 11.20: Applying borders
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4. In the Style box, select the type of line that you want.

5. To change the color of the border. Select the color from the color drop-down list.

6. Select the OK option to apply the borders

11.13 WORKING WITH GRAPHIC OBJECTS

Graphic objects can enhance the appearance of your worksheets by providing a whole
range of drawing options. You can create circles, squares and rectangles and include
them in your worksheets.  Using the buttons on the drawing toolbar. You can add various
2-3 dimensional objects to a worksheet. Excel has a new feature to offer, that is, the
AutoShape feature, which automatically defines shapes, such as arrows, stars, connectors,
banners, flowchart symbols and callout.  All these objects can be moved, resized and
formatted.

11.13.1    Adding Graphic Objects to a Worksheet

To add a graphics to your worksheets, the steps are:

1. Activate the sheet on which you want to display the graphic object.

2. If the Drawing toolbar is not displayed, then select the Toolbars option from the
View and select the Drawing toolbar as shown below.

3. Click on the button representing the object which you want to add. If you do not
want to use any of the available objects on the drawing toolbar, then click on the
AutoShape button.

4. Select a category of shapes from the resulting AutoShape menu and then select the
shape that you want to draw from given Figure 11.21.

5. Drag the mouse over the worksheet area where you want your object to appear.

6. To add a label in an object, enter the text while the object is selected.

7. You can change the properties of the shapes, make selections from Fill Color, Line
Color, Font Color and Line Style lists represented by buttons on the drawing toolbar.

8. Click elsewhere on the sheet to deselect the object or press escape.

11.13.2    Selecting, Resizing Objects

You can select, move and resize the objects in your worksheets. The following sub-
section briefly describes how you can select and resizing objects.

Figure 11.21: Adding graphic objects
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Selecting an Object

Select the object by placing the mouse pointer next to the object and then clicking on the
mouse button. The mouse pointer becomes an arrow when positioned properly on the
border of the object.  This indicates that the object has been correctly selected and then
the handles appear.

Resizing Objects

Select the object you want to resize.  The handles that appear around the object help you
to resize it.  Once the mouse pointer is positioned on one of the handles, it changes into a
double headed arrow. You can press the left mouse button and drag the handle till the
required size of the object is marked and then release the mouse button.

Formatting Objects

You can add color, patterns, and borders to drawn objects in your worksheets. You can
use the buttons available on the Drawing toolbar to format objects. You can also use the
Format AutoShape dialog box to format objects. To do so, the steps are:

1. Select the object you want to format.

2. Select the AutoShape option from the Format menu. The Format AutoShape dialog
box gets invoked.

You can also click on the right mouse button and select Format AutoShape command.

3. Select one of the four tabs according to the formatting changes that you want. The
four tabs are for Colours, Lines, Size, Protection and Properties.

4. Select the Ok option once the changes have been made.

11.13.3    Creating a Text Box

Text boxes can be introduced in your worksheets for adding paragraphs of text. To
create a text box, follow the steps listed herewith:

1. Select the Text box button from the drawing toolbar.

2. Position the mouse pointer on the worksheet. The mouse pointer will change into a
small cross.

3. Click on the left button, and drag the pointer in the area where you want your text to
appear.

4. Release the button and, at the insertion point that appears in the text box, start
entering your text.  The text wraps according to the size of the box as shown in
Figure 11.22.

Figure 11.22: Creating a Text Box
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11.14 CHARTS

Charts are introduced in worksheets to make analysis tasks easier. Charts are an effective
way of representing value through the visual presentation aid.  They not only enhance the
look of the worksheet but also allow a user to gather a lot of information in much lesser
time.

Growth rate analysis or monthly sales reports which would be a very tedious job can be
made quite interesting and time conserving if depicted through charts. To create a chart,
you must select a range of cells containing both labels and numeric values. Then you can
use the Chart Wizard button on the standard toolbar. Charts are created as chart sheets
in a workbook by default, or can be embedded in a worksheet. You can create a chart
using the Chart Wizard by following the steps listed herewith:

1. Select a range with numeric data and labels.

2. Click on the Chart Wizard tool on the standard toolbar.

When the mouse button is released, the chart wizard dialog box gets invoked as
shown in given Figure 11.23 (a). The chart wizard then guides you to different steps
of creating chart of your own choice.

3. Click on the Finish button to complete the process of creating charts. A chart using
the default format is drawn.

4. You can select the Next option to go to the next step which would show Step 2 of 4
dialog box as shown in Figure 11.23 (b) and in this manner, you can move to Step 3
to 4 and Step 4 of 4 dialog box to make your charts more detailed and according to
your convenience.

Figure 11.23 (a) : Chart Wizard Dialog Box Chart Type
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The Step 2 of 4 dialog box lets you specify your range of data that you want to
include in the chart as shown in Figure 11.24.

The Data Range tab displays the range recognized by the chart. If you need to
change it, then type in the new range.

The Series tab allows you to add and remove a data series. You can also specify the
x-axis labels.

Step 3 of 4 dialog box of the Chart Wizard has a number of tabs as can be seen in Figure
11.23 (c). Each one has a specific button to perform.

� Titles tab : adds/removes titles to charts.

� Axes : toggles the axis values on and off.

� Gridlines tab : displays gridlines parallel to x and y axis.

� Legend tab : toggles a legends on and off angles it, and places it to the charts.

� Data labels tab : adds or removes labels and values to series.

� Data table tab :  links or removes source data from the chart.

Figure 11.23 (b) : Chart Wizard Dialog Box — Chart Source

Figure 11.23 (c) : Chart Wizard Dialog Box Chart Options
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Figure 11.22 (d) illustrates the chart wizard ---- chart location window. This chart
wizard helps you to specify the location as an embedded chart on a worksheet, or
as a chart sheet.

5. Select the option As object in and click on Finish. Your final chart would be placed
on your worksheet.

Sample Chart is shown in Figure 11.23 (e) with the data present in the worksheet.

11.15 LET US SUM UP

Spreadsheet is a software which simulates a paper worksheet. MS Excel is a Windows-
based spreadsheet package. Movement in a worksheet is possible by using the keyboard,
mouse or the scroll bars. Data entry can be of text, numbers, date, and time. Series of
text, numbers, dates and time can be conveniently created. Saving a workbook saves all
the worksheets contained in it. Worksheets can also be saved in different formats. Making
modification in worksheet is possible. It can be done by editing a cell or a cell range.
Copying and moving data from one place to another in a worksheet can be done.
Worksheets can be inserted and renamed, and deletion of these worksheets is also
permitted.

Numeric formatting feature lets you change the appearance of the numeric entries. You
can have special formatting options for your worksheet data by using the custom number
format. You can also set your own date and time formats. Column width can be changed
by using the Format, Column, Width options. Row height can be altered by using Format,
Row, height option. Alignment of data in your worksheet can be controlled. You can have
horizontal and vertical alignment. You can have text control in cells also by using the
options Wrap text, Shrink to Fit, Merged cells and rotate text.

You can change the font and the font size of a text by selecting the Font tab from the
Format Cell dialog box. Patterns and borders tab in the Format Cell dialog box enables

Figure 11.23 (d) : Chart Wizard — Chart Location

Figure 11.23 (e) : Data Presented in Worksheet Sample Chart
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you to apply patterns and borders. Formatting attributes combine to make a style. You
can create your own style, define style, apply a style and deleting a style. Graphic objects
can be incorporated in worksheets to enhance its appearance. Charts can be embedded
in your worksheets by using the Chart Wizard feature of Excel.

11.16 CHECK YOUR PROGRESS EXERCISE

Check Your Progress Exercise

In the blank next to each of the following terms or phrases, write the name of the
corresponding terms or phrases:

1. Provides the information about the settings that are currently being used as well as
for date and time ...................................................................................................

2. A group of cells on which a operation is to be performed ....................................

3. A commonly used calculation that is built into the spreadsheet ............................

4. Designates the intersection of a row and column .................................................

5. Contains the main menu and the edit line .............................................................

6. A group of instructions that accomplishes a specific task ....................................

7. A number that can be used in mathematical operation .........................................

8. Indicates for operation currently being performed ...............................................

9. An equation entered into the spreadsheet by the user ..........................................

10. The Area when data can be entered or changed .................................................

11.17 ANSWERS TO CHECK YOUR PROGRESS
EXERCISE

1. Status line

2. Range

3. Function

4. Cell address

5. Control Panel

6. Macro

7. Value

8. Operating mode

9. Formula

10. Active Cell


